问题

最近终端总是弹出这么一句话,咱也不懂怎么解决。

Google baidu 也查不到问题。

小伙伴帮忙看一下。

每次新打开终端都会有这个 Warning 。

Warning: Calling `brew list` to only list formulae is deprecated! Use `brew list --formula` instead.

5eDhZb-ptj6gr

最后被逼无奈,在 V 站 发帖求助小伙伴, 结果还真找到了答案

解决方式

HvJSlT-Q0oUVr

最后找到问题所在,是因为按照网上的教程安装的 Coreutils

~/.zshrc 里改一下即可。

hAFz8B-HWsVNg

补充

写到这里,很多小伙伴应该已经知道问题所在了,可能有的小伙伴还不知道怎么解决:

  1. vim ~/.zshrc
  2. 找到使用 brew list 的地方
  3. brew list 改为 brew list --formula

如果还不知道怎么弄,那可以用编辑工具打开 .zshrc 文件,然后搜索找到 brew list ,然后替换。

上一篇 下一篇